Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1061312

Summary: [RFE][savanna]: Implement ACL using policies
Product: Red Hat OpenStack Reporter: RHOS Integration <rhos-integ>
Component: RFEsAssignee: RHOS Maint <rhos-maint>
Status: CLOSED UPSTREAM QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: markmc, yeylon
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/sahara/+spec/policy-based-acl
Whiteboard: upstream_milestone_next upstream_status_not-started upstream_definition_drafting
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-19 13:12:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description RHOS Integration 2014-02-04 15:53:53 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/savanna/+spec/policy-based-acl.

Description:

ACL should be implemented using oslo policy module.

It should provide an ability to check several roles such as admin, owner ant etc.

Specification URL (additional information):

None

Comment 1 Stephen Gordon 2014-03-12 15:38:25 UTC
*** Bug 1075387 has been marked as a duplicate of this bug. ***