Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1060983

Summary: [RFE][glance]: Replace mox with mock in glance unit tests
Product: Red Hat OpenStack Reporter: RHOS Integration <rhos-integ>
Component: RFEsAssignee: RHOS Maint <rhos-maint>
Status: CLOSED UPSTREAM QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: markmc, scohen, yeylon
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: 5.0 (RHEL 7)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/glance/+spec/replace-mox-with-mock
Whiteboard: upstream_milestone_ongoing upstream_status_started upstream_definition_approved
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-30 06:31:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description RHOS Integration 2014-02-04 05:07:04 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/glance/+spec/replace-mox-with-mock.

Description:

Mox should be replaced by mock in glance unit tests, because:
1) mox library's quality is worse than mock one's;
2) it's more difficult for a developer to write unit tests using mox than mock;
3) mox is not comparable with py3.

Specification URL (additional information):

None

Comment 1 Stephen Gordon 2014-02-06 14:11:10 UTC
Updating based on BP milestone