Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1059527

Summary: [BPM Example Documentation] How to know if the client jar ran successfully
Product: [Retired] JBoss BPMS Platform 6 Reporter: Alessandro Lazarotti <alazarot>
Component: DocumentationAssignee: Vikram Goyal <vigoyal>
Status: CLOSED CURRENTRELEASE QA Contact: Jan Hrcek <jhrcek>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.0.0CC: brms-docs, eschabel
Target Milestone: CR2   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-14 22:21:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alessandro Lazarotti 2014-01-30 04:50:59 UTC
Description of problem:

In the end of "Installing the BPM Suite Example App", it has the sentence:
"A successful execution will load these processes in your BPM Suite Server."

However the guide does not say to users how to verify if the sentence above is true. 

A simple note saying: 

"A successful execution will load these processes in your BPM Suite Server. Check the server log to see the application log outputs". 

... can help the user to verify if the client execution really happened.


Version-Release number of selected component (if applicable):
6.0.0 CR2

Comment 1 Vikram Goyal 2014-01-30 05:17:52 UTC
Thanks. This has now been fixed [1].

[1] http://docbuilder.usersys.redhat.com/22502/#Installing_the_BPM_Suite_Example_App

Comment 2 Eric D. Schabell 2014-01-30 11:19:28 UTC
I have added this to the GA branch of the demo projects I have for the field, good idea Alessandro. Output now looks like this for me:

https://github.com/eschabell/bpms-generic-loan-demo/tree/GA

$ java -jar jboss-generic-loan-demo-client.jar erics bpmsuite
Successfully loaded processes into your JBoss BPM Suite Server. Check the server log to see the application log outputs.


https://github.com/eschabell/bpms-mortgage-demo/tree/GA

$ java -jar jboss-mortgage-demo-client.jar erics bpmsuite
Successfully loaded processes into your JBoss BPM Suite Server. Check the server log to see the application log outputs.