Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1059242

Summary: /etc/pki/ovirt-engine/cacert.conf is missing in 3.2 installation
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engine-setupAssignee: Yedidyah Bar David <didi>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: high Docs Contact:
Priority: high    
Version: 3.3.0CC: acathrow, adahms, alonbl, bazulay, cfrancio, didi, gklein, iheim, lyarwood, mkalinin, npatil, pstehlik, Rhev-m-bugs, sbonazzo, scohen, tdosek, yeylon
Target Milestone: ---Keywords: ZStream
Target Release: 3.3.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: integration
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, upgrading from Red Hat Enterprise Virtualization Manager version 3.1 to 3.2 and then from 3.2 to 3.3 would fail if cacert.conf was missing. Now, engine-setup takes this into account.
Story Points: ---
Clone Of: 1049619 Environment:
Last Closed: 2014-02-27 09:32:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1049619    
Bug Blocks:    

Comment 1 Sandro Bonazzola 2014-01-31 14:46:55 UTC
Merged on rhevm-setup-plugins-3.3 branch.

Comment 3 Jiri Belka 2014-02-11 13:40:53 UTC
ok, rhevm-setup-plugins-3.3.1-1.el6ev.noarch

Verified based on alonbl@ comments: cp -a /etc/pki/ovirt-engine /etc/pki/rhevm-old, rm -f /etc/pki/ovirt-engine/cacert.conf and then engine-setup to upgrade rhevm. After upgrade /etc/pki/ovirt-engine/cacert.conf exists.

Comment 5 errata-xmlrpc 2014-02-27 09:32:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0220.html