Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1058768

Summary: OSGi subsystem does not honor patching mechanism
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Jitka Kozana <jkudrnac>
Component: DocumentationAssignee: eap-docs <eap-docs>
Status: CLOSED WONTFIX QA Contact: Jitka Kozana <jkudrnac>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 6.2.1CC: jkudrnac, myarboro, nziakova, rdickens, sgilda, smumford, thomas.diesler
Target Milestone: ---Keywords: Reopened
Target Release: EAP 6.2.4   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
The OSGi +helloworld+ quickstart does not deploy successfully in JBoss EAP 6. This is a known issue as the OSGi component has been deprecated in the product. This issue will not be resolved.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-09 12:40:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jitka Kozana 2014-01-28 13:56:21 UTC
The quickstart helloworld-osgi cannot be deployed to EAP version 6.2.1.CP.CR3. This quickstart (the produced jar) can be deployed on EAP 6.2.0.GA without any issues. 

How to reproduce:
Follow instructions in README.md in the helloworld-osgi quickstart. The build of the application can be completed without problems. However, the deploy (even manual one), fails with the following exception:


14:35:09,638 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015876: Starting deployment of "jboss-helloworld-osgi.jar" (runtime-name: "jboss-helloworld-osgi.jar")
14:35:09,720 INFO  [org.jboss.osgi.framework] (MSC service thread 1-5) JBOSGI011006: OSGi Framework - 2.1.0.Final-redhat-1
14:35:09,864 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jbosgi.BootstrapBundles.INSTALL: org.jboss.msc.service.StartException in service jbosgi.BootstrapBundles.INSTALL: JBAS011955: Failed to process initial capabilities
	at org.jboss.as.osgi.service.BootstrapBundlesIntegration.start(BootstrapBundlesIntegration.java:160)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_04]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_04]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_04]
Caused by: org.osgi.framework.BundleException: JBOSGI010318: Cannot get manifest from: vfs:/home/jkudrnac/jboss/jboss-eap-6.2.1.CP.CR3/jboss-eap-6.2/bundles/system/layers/base/org/jboss/as/osgi/configadmin/main/jboss-as-osgi-configadmin-7.3.0.Final-redhat-14.jar
	at org.jboss.osgi.spi.BundleInfo.<init>(BundleInfo.java:138)
	at org.jboss.osgi.spi.BundleInfo.createBundleInfo(BundleInfo.java:110)
	at org.jboss.as.osgi.service.BootstrapBundlesIntegration.getDeploymentFromURL(BootstrapBundlesIntegration.java:285)
	at org.jboss.as.osgi.service.BootstrapBundlesIntegration.getInitialBundleDeployment(BootstrapBundlesIntegration.java:241)
	at org.jboss.as.osgi.service.BootstrapBundlesIntegration.start(BootstrapBundlesIntegration.java:156)
	... 5 more
Caused by: java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method) [rt.jar:1.7.0_04]
	at java.util.zip.ZipFile.<init>(ZipFile.java:214) [rt.jar:1.7.0_04]
	at java.util.zip.ZipFile.<init>(ZipFile.java:144) [rt.jar:1.7.0_04]
	at java.util.jar.JarFile.<init>(JarFile.java:152) [rt.jar:1.7.0_04]
	at java.util.jar.JarFile.<init>(JarFile.java:116) [rt.jar:1.7.0_04]
	at org.jboss.vfs.spi.JavaZipFileSystem.<init>(JavaZipFileSystem.java:94)
	at org.jboss.vfs.spi.JavaZipFileSystem.<init>(JavaZipFileSystem.java:81)
	at org.jboss.vfs.VFS.mountZip(VFS.java:386)
	at org.jboss.vfs.VFS.mountZip(VFS.java:410)
	at org.jboss.osgi.vfs30.VirtualFileAdaptor30.ensureMounted(VirtualFileAdaptor30.java:321)
	at org.jboss.osgi.vfs30.VirtualFileAdaptor30.getMountedChild(VirtualFileAdaptor30.java:304)
	at org.jboss.osgi.vfs30.VirtualFileAdaptor30.getChild(VirtualFileAdaptor30.java:201)
	at org.jboss.osgi.vfs.VFSUtils.getManifest(VFSUtils.java:71)
	at org.jboss.osgi.spi.BundleInfo.<init>(BundleInfo.java:133)
	... 9 more

14:35:10,083 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS015870: Deploy of deployment "jboss-helloworld-osgi.jar" was rolled back with the following failure message: 
{
    "JBAS014671: Failed services" => {"jbosgi.BootstrapBundles.INSTALL" => "org.jboss.msc.service.StartException in service jbosgi.BootstrapBundles.INSTALL: JBAS011955: Failed to process initial capabilities
    Caused by: org.osgi.framework.BundleException: JBOSGI010318: Cannot get manifest from: vfs:/home/jkudrnac/jboss/jboss-eap-6.2.1.CP.CR3/jboss-eap-6.2/bundles/system/layers/base/org/jboss/as/osgi/configadmin/main/jboss-as-osgi-configadmin-7.3.0.Final-redhat-14.jar
    Caused by: java.util.zip.ZipException: error in opening zip file"},
    "JBAS014771: Services with missing/unavailable dependencies" => [
        "jbosgi.PersistentBundles.INSTALL is missing [jbosgi.BootstrapBundles.COMPLETE]",
        "jbosgi.internal.framework.INIT is missing [jbosgi.PersistentBundles.COMPLETE, jbosgi.BootstrapBundles.COMPLETE]"
    ]
}
14:35:10,092 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment jboss-helloworld-osgi.jar (runtime-name: jboss-helloworld-osgi.jar) in 10ms

Looks like the OSGi subsystem is not using the patched version, but the original one, which was made unusable by patching mechanism. 
[jkudrnac@jkudrnac jboss-eap-6.2]$ find . -name jboss-as-osgi-configadmin* 
./bundles/system/layers/base/org/jboss/as/osgi/configadmin/main/jboss-as-osgi-configadmin-7.3.0.Final-redhat-14.jar
./bundles/system/layers/base/.overlays/layer-base-jboss-eap-6.2.1.CP/org/jboss/as/osgi/configadmin/main/jboss-as-osgi-configadmin-7.3.1.Final-redhat-2.jar

Comment 1 Thomas Diesler 2014-01-30 07:22:09 UTC
Unassigned. OSGi has been removed from product/project. There has never been a support obligation for it. You can safely close all OSGi related bugs as "Won't fix" and perhaps even delete the OSGi component.

Comment 3 Thomas Diesler 2014-02-05 10:47:45 UTC
Won't Fix. OSGi has been removed from product/project. There has never been a support obligation for it. All OSGi related bugs can safely be closed as "Won't fix" and the OSGi component can perhaps even be deleted.

Comment 6 Scott Mumford 2014-02-27 04:59:19 UTC
Added draft release note.