Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1058761

Summary: RHEL7 RAM requirements
Product: Red Hat Satellite 5 Reporter: Lukáš Hellebrandt <lhellebr>
Component: VirtualizationAssignee: Stephen Herr <sherr>
Status: CLOSED ERRATA QA Contact: Dimitar Yordanov <dyordano>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 560CC: dyordano, ggruner, jhutar, mzazrivec, xdmoon
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: spacewalk-java-2.0.2-59 Doc Type: Bug Fix
Doc Text:
Cause: RHEL 7 now requires 1GB of ram for a successful installation. Consequence: Satellite 5.6 was only giving RHEL 7 guests 756 MB of ram by default. This caused the guest provisioning to fail. Fix: Increase ram given to RHEL 7 guests to 1GB. Result: Guest provisioning now works correctly.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-03 09:15:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 924189    

Description Lukáš Hellebrandt 2014-01-28 13:45:01 UTC
Description of problem:

In Satellite, there is 768MB set as minimal amount of RAM for a RHEL7 machine.
Such a little memory leads to RHEL7 not being restarted after kickstart.
Official minimum memory requirement for RHEL7 is 1024MB.

How reproducible:
Create a new kickstart for a virtual machine, RHEL7, 768MB RAM.
rhn_check on a host.

Actual results:
After machine installation, the system doesn't restart (No warnings)

Expected results:
System should restart after being installed

Additional info:
After setting to 1024 everything works fine.
Possibly related: bug 1034774

Comment 1 Milan Zázrivec 2014-01-28 13:49:03 UTC
I'm assigning this to Stephen, who has been active with this problem before.

Comment 2 Stephen Herr 2014-01-28 16:28:19 UTC
Hmm, previously the RHEL 7 guest memory requirements were raised from 512 MB to 768 MB in bug 1034774, but it looks like that is no longer enough.

Committing to Spacewalk master:
99136ca0d6c6dbab60ff345dc0170646175195e6

Comment 4 Milan Zázrivec 2014-02-21 10:18:22 UTC
satellite.git SATELLITE-5.6: 4b690fb81f11715f9ef1c51fb668f1379a49e0c1

Comment 7 errata-xmlrpc 2014-03-03 09:15:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0228.html