Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1058361

Summary: Package Management Faild to Remove Old Version
Product: [Fedora] Fedora Reporter: KitchM <tech>
Component: kde-settingsAssignee: Rex Dieter <rdieter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 20CC: dvratil, jgrulich, jreznik, kevin, ltinkl, mbriza, rdieter, rnovacek, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-27 17:46:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description KitchM 2014-01-27 16:13:15 UTC
Description of problem:yum check found kde-settings-kdm-20-12.fc20.noarch is a duplicate with kde-settings-kdm-19-23.fc19.noarch



Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1.yum remove kde-settings-kdm-19-23.fc19.noarch
2. no joy
3.

Actual results: yum remove kde-settings-kdm-19-23.fc19.noarch
Loaded plugins: aliases, auto-update-debuginfo, changelog, fastestmirror, filter-
              : data, fs-snapshot, keys, list-data, merge-conf, post-transaction-
              : actions, priorities, protectbase, ps, refresh-packagekit, remove-
              : with-leaves, rpm-warm-cache, tmprepo, tsflags, upgrade-helper,
              : verify, versionlock
Resolving Dependencies
--> Running transaction check
---> Package kde-settings-kdm.noarch 0:19-23.fc19 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================
 Package                 Arch          Version              Repository        Size
===================================================================================
Removing:
 kde-settings-kdm        noarch        19-23.fc19           installed         32 k

Transaction Summary
===================================================================================
Remove  1 Package

Installed size: 32 k
Is this ok [y/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
/var/tmp/rpm-tmp.NTW7H5: line 1: fg: no job control
error: %preun(kde-settings-kdm-19-23.fc19.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch
  Verifying  : kde-settings-kdm-19-23.fc19.noarch                              1/1 

Failed:
  kde-settings-kdm.noarch 0:19-23.fc19                                             

Complete!



Expected results: obviously should have removed dup


Additional info:

Comment 1 Rex Dieter 2014-01-27 17:46:15 UTC
See:
https://fedoraproject.org/wiki/Common_F20_bugs#preun-fail

*** This bug has been marked as a duplicate of bug 989145 ***