Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1058221

Summary: [RFE][neutron]: Config extension plugin by names
Product: Red Hat OpenStack Reporter: Nir Yechiel <nyechiel>
Component: openstack-packstackAssignee: Gaël Chamoulaud <gchamoul>
Status: CLOSED CURRENTRELEASE QA Contact: Alexander Stafeyev <astafeye>
Severity: low Docs Contact:
Priority: medium    
Version: 5.0 (RHEL 7)CC: aortega, chrisw, gchamoul, jpena, lbezdick, markmc, mlopes, nbarcet, nyechiel, rhos-integ, srevivo, twilson
Target Milestone: asyncKeywords: FutureFeature, Triaged, ZStream
Target Release: 6.0 (Juno)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/neutron/+spec/config-plugin-by-name
Whiteboard: upstream_milestone_icehouse-3 upstream_status_implemented upstream_definition_discussion
Fixed In Version: openstack-packstack-2014.2-0.26.dev1474.gd85ee76.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1048419
: 1083800 (view as bug list) Environment:
Last Closed: 2016-05-12 13:42:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1048419, 1082450    
Bug Blocks: 1003878, 1083800    

Comment 1 Arthur Berezin 2014-01-27 09:32:21 UTC
Openstack Puppet modules should reflect changes introduces to upstream Neutron configuration file.

Comment 4 Terry Wilson 2014-03-26 23:26:02 UTC
The upstream docs in manifests/init.pp already show using the short names. It is just an array that is passed in for service_plugins, so I'm not sure what needs to be done here?

Comment 6 Nir Yechiel 2014-06-08 11:47:08 UTC
*** Bug 1048419 has been marked as a duplicate of this bug. ***

Comment 16 Javier Peña 2015-08-26 10:18:39 UTC
Setting the product to openstack-packstack to reflect what the patch does.

Comment 17 Javier Peña 2015-08-27 15:04:20 UTC
Backport for Juno: https://review.openstack.org/217736

Comment 18 Nir Yechiel 2015-09-24 11:09:16 UTC
Hi, 

Can you please update this BZ? Can we just close it or move to QE?

Thanks,
Nir

Comment 19 Gaël Chamoulaud 2015-09-25 07:57:17 UTC
Hi Nir, 

This bug has already been fixed and included in openstack-packstack-2014.2-0.26.dev1474.gd85ee76.el7ost since 2015-08-28. So this bz should be moved to QE.

Thx, Gaël

Comment 20 Toni Freger 2015-10-06 08:18:52 UTC
Alex, during the verification please check two options, as described in blueprint: https://blueprints.launchpad.net/neutron/+spec/config-plugin-by-name

First check with new classes:
service_plugins = router,firewall,lbaas,vpnaas,metering 

Then check with mixed classes:
service_plugins = router, neutron.services.firewall.fwaas_plugin:FirewallPlugin, lbaas


Those two methods should work.

Comment 21 Alexander Stafeyev 2015-10-07 06:45:54 UTC
Hi 
I changed the service plugins on my setup to "service_plugins = router,firewall,lbaas", restarted the neutron service and verified that the neutron agent are ok. Created a router and it was in active state. 

Same with mixed service plugin names ( service_plugins =neutron.services.loadbalancer.plugin.LoadBalancerPlugin,router,neutron.services.firewall.fwaas_plugin.FirewallPlugin) 


all seemed to be ok 

Is there any other specific tests I should perform before verifying the bug ? 
tnx

Comment 22 Alexander Stafeyev 2015-10-11 06:25:31 UTC
Hi 
I changed the service plugins on my setup to "service_plugins = router,firewall,lbaas", restarted the neutron service and verified that the neutron agent are ok. Created a router and it was in active state. 

Same with mixed service plugin names ( service_plugins =neutron.services.loadbalancer.plugin.LoadBalancerPlugin,router,neutron.services.firewall.fwaas_plugin.FirewallPlugin) 


all seemed to be ok 

Is there any other specific tests I should perform before verifying the bug ? 
tnx

Comment 23 Gaël Chamoulaud 2015-10-12 13:31:26 UTC
Hi Alexander,

Thanks, it should be ok for the tests!

Gaël