Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1058027

Summary: SELinux is preventing /usr/libexec/nm-ssh-service from 'search' accesses on the directory keyring-bEtvfk.
Product: [Fedora] Fedora Reporter: Elad Alfassa <elad>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: dominick.grift, dwalsh, lvrabec, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9f3416bb251ec8a76221d25bfa5a468097c15d89f131e96deadc9bd19ebd5028
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-27 11:11:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Elad Alfassa 2014-01-26 14:36:52 UTC
Description of problem:
This happened when I installed the NetworkManager ssh plugin and configured it to authenticate using "SSH Agent"
SELinux is preventing /usr/libexec/nm-ssh-service from 'search' accesses on the directory keyring-bEtvfk.

This happened when I tried to use the NetworkManager ssh plugin and set it to authenticate using "ssh agent"

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that nm-ssh-service should be allowed search access on the keyring-bEtvfk directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep nm-ssh-service /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                unconfined_u:object_r:gkeyringd_tmp_t:s0
Target Objects                keyring-bEtvfk [ dir ]
Source                        nm-ssh-service
Source Path                   /usr/libexec/nm-ssh-service
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           NetworkManager-
                              ssh-0.9.1-0.5.20130706git6bf4649.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-119.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.8-300.fc20.x86_64 #1 SMP Thu
                              Jan 16 01:07:50 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-01-26 16:34:10 IST
Last Seen                     2014-01-26 16:34:10 IST
Local ID                      7c9f7125-0a69-4352-b897-bcc3e6b3acf6

Raw Audit Messages
type=AVC msg=audit(1390746850.9:334): avc:  denied  { search } for  pid=6527 comm="nm-ssh-service" name="keyring-bEtvfk" dev="tmpfs" ino=1574657 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=unconfined_u:object_r:gkeyringd_tmp_t:s0 tclass=dir


type=SYSCALL msg=audit(1390746850.9:334): arch=x86_64 syscall=access success=no exit=EACCES a0=21a0640 a1=0 a2=d a3=7fff51e40f10 items=0 ppid=458 pid=6527 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=nm-ssh-service exe=/usr/libexec/nm-ssh-service subj=system_u:system_r:NetworkManager_t:s0 key=(null)

Hash: nm-ssh-service,NetworkManager_t,gkeyringd_tmp_t,dir,search

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.12.8-300.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-27 11:11:17 UTC

*** This bug has been marked as a duplicate of bug 1058028 ***