Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1056572

Summary: [host-deploy] terminate event is not received by engine although sent by host
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engineAssignee: Alon Bar-Lev <alonbl>
Status: CLOSED ERRATA QA Contact: Tareq Alayan <talayan>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.2.0CC: aberezin, acathrow, adahms, alonbl, bazulay, emesika, gklein, iheim, lpeer, pkliczew, pstehlik, Rhev-m-bugs, yeylon
Target Milestone: ---Keywords: ZStream
Target Release: 3.3.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: is34 Doc Type: Bug Fix
Doc Text:
Previously, apache-sshd would not flush streams or close streams after a command had been executed. This would result in data not being written to stream readers. With this update, the flush action has been made explicit, making it possible to correctly write data.
Story Points: ---
Clone Of: 1051035 Environment:
Last Closed: 2014-03-03 13:31:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1051035    
Bug Blocks:    

Comment 2 Tareq Alayan 2014-02-06 15:50:35 UTC
Can you please help in how to verify this fix?

Comment 3 Alon Bar-Lev 2014-02-06 15:53:51 UTC
(In reply to Tareq Alayan from comment #2)
> Can you please help in how to verify this fix?

I have no idea!
I have not succeeded in reproducing that on my setup.
I can only guess that the chance is higher as the communication between engine and host is faster, same host is best...

Comment 4 Alon Bar-Lev 2014-02-06 15:54:55 UTC
Please note that this issue exists in 3.2 as well, and we got no confirmed customer report regarding it.

Comment 5 Tareq Alayan 2014-02-09 14:31:55 UTC
moved to verified. Ran automatic sanity test on with no problems.
no clear way to reproduce manually,

Comment 7 errata-xmlrpc 2014-03-03 13:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0227.html