Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1056381

Summary: [RFE][nova]: Disable file injection by default
Product: Red Hat OpenStack Reporter: RHOS Integration <rhos-integ>
Component: openstack-novaAssignee: RHOS Maint <rhos-maint>
Status: CLOSED ERRATA QA Contact: Ami Jeain <ajeain>
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: markmc, ndipanov, rbryant, sgordon, slong, vpopovic, yeylon
Target Milestone: Upstream M3Keywords: FutureFeature
Target Release: 5.0 (RHEL 7)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/nova/+spec/disable-file-injection-by-default
Whiteboard: upstream_milestone_icehouse-3 upstream_status_implemented upstream_definition_approved
Fixed In Version: openstack-nova-2014.1-3.el7ost Doc Type: Deprecated Functionality
Doc Text:
File injection into VM images is now deprecated; instead, Red Hat recommends that you use the ConfigDrive and metadata server facilities to modify guests at launch. File injection is now disabled by default in OpenStack Compute. To enable file injection, modify the inject_key and inject_partition configuration keys in /etc/nova/nova.conf and restart the Compute services. Note that the file-injection mechanism will probably be disabled in a future release.
Story Points: ---
Clone Of:
: 1082398 (view as bug list) Environment:
Last Closed: 2014-07-08 15:28:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1082398    

Description RHOS Integration 2014-01-22 05:04:06 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/disable-file-injection-by-default.

Description:

With ConfigDrive and Metadata service combined there is no need for fiddling inside VM images at deployment time - images can consult metadata locally (configdrive) or network (metadata service).

Disabling it by default is thus sane, and we can review whether to deprecate and remove it entirely in future.

Specification URL (additional information):

None

Comment 1 Stephen Gordon 2014-02-06 14:09:11 UTC
Updating based on BP milestone

Comment 8 errata-xmlrpc 2014-07-08 15:28:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0853.html