Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1056364

Summary: postgrey.service has syntax error in recent update
Product: [Fedora] Fedora Reporter: Mark Mielke <mark>
Component: postgreyAssignee: Matthias Saou <matthias>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 20CC: i, mark, matthias
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-23 03:40:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mark Mielke 2014-01-22 04:08:45 UTC
Description of problem:

After recent update, probably 1.34-9, postgrey no longer starts.

In postgrey.service, it lists:

ExecStart=/usr/sbin/postgrey \
 --unix=/var/spool/postfix/postgrey/socket \
 --pidfile=/var/run/postgrey.pid \
 --group=postgrey \
 --user=postgrey \
 --greylist-text="Greylisted for %%s seconds"
 --daemonize \
 $POSTGREY_OPTS


The line starting with --greylist-text appears to be missing a "\" at the end of line. I added " \" manually and the problem appears to be fixed.

Version-Release number of selected component (if applicable):

1.34-10


How reproducible:

Visible on at least two machines now.

Comment 1 Christopher Meng 2014-01-23 03:40:59 UTC
Thanks for your report, my fault.

*** This bug has been marked as a duplicate of bug 1055638 ***