Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1055598

Summary: Prefer gpg2 over gpg
Product: [Fedora] Fedora Reporter: Michael Catanzaro <mcatanzaro>
Component: evolutionAssignee: Matthew Barnes <mbarnes>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 20CC: fabiano, lucilanga, mbarnes, mcrha
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: evolution-data-server-3.10.4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-21 07:27:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Catanzaro 2014-01-20 15:27:12 UTC
Description of problem: Installing spamassassin (for a standard jhbuild sysdeps --install) or duplicity (for Deja Dup) breaks PGP gnome-keyring integration because it pulls in the original gnupg, which seems to be preferred over gnupg2 (at least by Evolution) and doesn't use gpg agents without special modification to gpg.conf.


Version-Release number of selected component (if applicable): 3.10.3-1.fc20


How reproducible: Always


Steps to Reproduce:
1. In Evolution, configure an email address to use PGP
2. Send some signed mail and tell gnome-keyring to remember your PGP password
3. Send some more signed mail to verify that it's working
4. Install spamassassin or deja-dup, pulling in the original gnupg


Actual results: After installing the unrelated package, you are prompted for your PGP password each time you want to send an email.


Expected results: Installing unrelated packages does not cause Evolution to stop using my stored PGP password.


Additional info: Also filed against duplicity as Bug #105589, against spamassassin as Bug #105593.

Comment 1 Michael Catanzaro 2014-01-20 15:29:14 UTC
I guess I would expect Evolution in Fedora to check for the newer gnupg2 and only use the original as a fallback.

(In reply to Michael Catanzaro from comment #0)
> Additional info: Also filed against duplicity as Bug #105589, against
> spamassassin as Bug #105593.

Let's try again: Bug #1055589 and Bug #1055593

Comment 2 Milan Crha 2014-01-21 07:27:10 UTC
Thanks for a bug report. The gpg2 support was added as a fix for bug #985599, and I left gpg as default probably just because it was here sooner than gpg2. I do not mind that much, thus I changed the order upstream:

Created commit 7a73cb2 in eds master (3.11.5+) [1]
Created commit 9cbb038 in eds gnome-3-10 (3.10.4+)

[1] https://git.gnome.org/browse/evolution-data-server/commit/?id=7a73cb2