Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1055518

Summary: before_device_migrate_source not being called
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: vdsmAssignee: Vinzenz Feenstra [evilissimo] <vfeenstr>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.3.0CC: abaron, aberezin, bazulay, danken, gklein, iheim, lpeer, pstehlik, vfeenstr, ybronhei, yeylon, zdover
Target Milestone: ---Keywords: ZStream
Target Release: 3.3.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: is34 Doc Type: Bug Fix
Doc Text:
before_device_migrate_source is now called by VDSM as expected.
Story Points: ---
Clone Of: 1048763 Environment:
Last Closed: 2014-02-27 09:43:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1048763    
Bug Blocks:    

Comment 3 Jiri Belka 2014-02-05 10:14:16 UTC
ok, vdsm-4.13.2-0.8.el6ev.x86_64

# engine-config -a | grep -i 'customdevice.*3\.3'
CustomDeviceProperties: {type=interface;prop={dhcp=^(true|false)$}} version: 3.3

I created two hooks, before_device_create and this one - before_device_migrate_source. Both hooks were executed, during VM's start-up and during migration.

# grep -i 'execcmd.*hook' /var/log/vdsm/vdsm.log | grep 00| tail -n2
Thread-27108::DEBUG::2014-02-05 10:01:36,639::utils::505::root::(execCmd) '/usr/libexec/vdsm/hooks/before_device_create/00_test' (cwd None)
Thread-27138::DEBUG::2014-02-05 10:02:19,494::utils::505::root::(execCmd) '/usr/libexec/vdsm/hooks/before_device_migrate_source/00_test' (cwd None)

Comment 5 errata-xmlrpc 2014-02-27 09:43:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0219.html