Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1055076

Summary: firewalld 0.3.9 broke pppoe
Product: [Fedora] Fedora Reporter: Serge Pavlovsky <pal666>
Component: firewalldAssignee: Thomas Woerner <twoerner>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 20CC: jpopelka, pal666, r.liverovskiy, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-24 09:11:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Serge Pavlovsky 2014-01-18 15:55:17 UTC
Description of problem:

under 0.3.8:

---------------
[root@underdark 1]# iptables-save | grep ppp0
-A POSTROUTING_ZONES -o ppp0 -j POST_external
-A PREROUTING_ZONES -i ppp0 -j PRE_external
-A PREROUTING_ZONES -i ppp0 -j PRE_external
-A FORWARD_IN_ZONES -i ppp0 -j FWDI_external
-A FORWARD_OUT_ZONES -o ppp0 -j FWDO_external
-A INPUT_ZONES -i ppp0 -j IN_external
--------------

under 0.3.9:
---------------
[root@underdark 1]# iptables-save | grep ppp0
[root@underdark 1]# firewall-cmd --zone=external --add-interface=ppp0
Error: %x format: a number is required, not NoneType
----------------

downgrade to 0.3.8 fixes this problem

i must say that even before 0.3.9 it didn't react on upping pppoe interface when firewalld was already running, but at least it was able to understand that ppoe is up during startup, so i used nm dispatcher hook to restart firewalld after upping pppoe
0.3.9 broke even that

seriously, i can't be the only one using pppoe in fedora

Comment 1 Jiri Popelka 2014-01-20 12:15:38 UTC
Could you try 0.3.9.2 ? It should already be in stable.

Comment 2 Serge Pavlovsky 2014-01-20 21:16:27 UTC
actually when i said 0.3.9 it was 0.3.9.2

Comment 3 Thomas Woerner 2014-01-21 11:15:05 UTC
With version 0.3.9.2 this is working as expected for me.

Please provide the output of
1) rpm -q firewalld
2) rpm -V firewalld

Comment 4 Serge Pavlovsky 2014-01-21 12:30:53 UTC
# rpm -q firewalld
firewalld-0.3.9.2-1.fc20.noarch
# rpm -V firewalld; echo $?
0

Comment 5 Roman I. Liverovskiy 2014-01-24 06:51:59 UTC
I also have this bug on Fedora 20 with firewalld-0.3.9.2-1.fc20.
If add port forwarding, for example:

# firewall-cmd --permanent --zone=public --add-forward-port=port=33895:proto=tcp:toport=5900

and then when i try to reload:

# firewall-cmd --reload

i have an error:

Error: %x format: a number is required, not NoneType

without port forwarding all works well.

Comment 6 Jiri Popelka 2014-01-24 09:11:28 UTC

*** This bug has been marked as a duplicate of bug 1056154 ***