Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1048763

Summary: before_device_migrate_source not being called
Product: Red Hat Enterprise Virtualization Manager Reporter: Assaf Muller <amuller>
Component: vdsmAssignee: Vinzenz Feenstra [evilissimo] <vfeenstr>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.3.0CC: aberezin, bazulay, danken, iheim, lpeer, pstehlik, sbonazzo, vfeenstr, ybronhei, yeylon, zdover
Target Milestone: ---Keywords: ZStream
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: ovirt-3.4.0-beta2 Doc Type: Bug Fix
Doc Text:
VDSM now calls before_device_migrate_source.
Story Points: ---
Clone Of:
: 1055518 (view as bug list) Environment:
Last Closed: 2014-06-09 13:27:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1055518, 1078909, 1142926    

Description Assaf Muller 2014-01-06 10:19:46 UTC
Description of problem:
before_device_migrate_source is no longer being called by VDSM

Comment 4 Jiri Belka 2014-02-18 11:06:06 UTC
ok, vdsm-4.14.1-2.el6.x86_64

part of vdsm.log:

Thread-928::DEBUG::2014-02-18 10:45:41,473::utils::555::root::(execCmd) '/usr/libexec/vdsm/hooks/before_device_migrate_source/00_test' (cwd None)

output of my hook:

Feb 18 10:45:41 dell-r210ii-03 vdsm-00_test: dhcp=true

Comment 7 errata-xmlrpc 2014-06-09 13:27:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html