Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1044068

Summary: vmHotplugDisk failed with "VolumeError: Bad volume specification"
Product: Red Hat Enterprise Virtualization Manager Reporter: Nir Soffer <nsoffer>
Component: vdsmAssignee: Nir Soffer <nsoffer>
Status: CLOSED ERRATA QA Contact: Aharon Canan <acanan>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.3.0CC: amureini, bazulay, ebenahar, eedri, iheim, kjachim, lpeer, nsoffer, obasan, sbonazzo, scohen, sgrinber, yeylon, ykaul, zdover
Target Milestone: ---Keywords: ZStream
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: storage
Fixed In Version: ovirt-3.4.0-beta2 Doc Type: Bug Fix
Doc Text:
Previously, attaching an iSCSI disk to a running virtual machine failed with the following error: "VolumeError: Bad volume specification". The logs reported that the LUN existed on the storage server adn the storage server was connected. vmHotplugDisk now adds a hot-plugged iSCSI disk successfully.
Story Points: ---
Clone Of: 923773
: 1066413 (view as bug list) Environment:
Last Closed: 2014-06-09 13:27:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 923773    
Bug Blocks: 1066413, 1078909, 1142926    
Attachments:
Description Flags
verifying vdsm log. none

Comment 9 Eyal Edri 2014-02-10 10:15:58 UTC
moving to 3.3.2 since 3.3.1 was built and moved to QE.
please make sure to clone bugs to z-stream to make it the zstream.

Comment 11 Carlos Mestre González 2014-02-18 13:43:08 UTC
Confirm it worked in ovirt-engine-3.4.0-0.7.beta2 (vdsm version is 
vdsm-4.14.1-3.)

Attached vdsm log where vmHotplugDisk successes.

Comment 12 Carlos Mestre González 2014-02-18 13:44:38 UTC
Created attachment 864563 [details]
verifying vdsm log.

vmHotplugDisk adds hot plug disk successfully

Comment 16 errata-xmlrpc 2014-06-09 13:27:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html