Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1018416

Summary: PRD35 - [RFE] History DB should sync user's first and last name for user usage tables.
Product: Red Hat Enterprise Virtualization Manager Reporter: Simon Sekidde <ssekidde>
Component: ovirt-engine-dwhAssignee: Shirly Radco <sradco>
Status: CLOSED ERRATA QA Contact: movciari
Severity: high Docs Contact:
Priority: high    
Version: 3.2.0CC: aberezin, audgiri, bazulay, gklein, iheim, juwu, lnovich, movciari, pstehlik, rbalakri, Rhev-m-bugs, sbonazzo, sherold, ssekidde, yeylon, ylavi
Target Milestone: ---Keywords: FutureFeature, Reopened
Target Release: 3.5.0   
Hardware: All   
OS: Linux   
Whiteboard: infra
Fixed In Version: ovirt-3.5.0-alpha1 Doc Type: Enhancement
Doc Text:
It is now possible to create ad hoc reports that have full details of users including more information than the user's ID number. The user's first and last name will now be visible on the report as well.
Story Points: ---
Clone Of:
: 1091687 (view as bug list) Environment:
Last Closed: 2015-02-11 18:14:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1091687, 1142923, 1156165    

Description Simon Sekidde 2013-10-11 23:20:47 UTC
Description of problem:

Hi Yaniv, 

Adding the follow up questions in bugzilla from the inital email I sent dated below:

> From: "Simon Sekidde" <ssekidde@redhat.com>
> To: "Yaniv Dary" <ydary@redhat.com>
> Sent: Tuesday, September 17, 2013 10:28:30 PM
> Subject: Questions regarding RHEVM reports on 3.2

>
> 3. Add - hoc report prompted for user ID twice in DEV env
> When a user creates an ad-hoc report in RHEV 3.2 or RHEV 3.1 and select one
> of the download capabilities they get prompted for a user ID/PW twice. Is
> this expected or should we just ignore these and run the report?

I don't understand the flow. Please explain.
Screenshots? logs?

I logon to the reports Portal and run a report and it runs fine. I then select download to Excel, it starts running and then pops up with a logon the the Portal Again. I can click through that and then it pops up again and I click through it.   
Maura

>
> 5. Reports need to show user names not just IDs
> We need a report that shows user names – not just IDs like "e12345678@domain"
> is this in the works?

Where do you see user IDs?
To my understanding "e12345678@domain" is [username]@[domain], is not what you are looking for?

To make the report valuable, we need the actual name of the user. If RH has this then that would be ideal.  Otherwise we have to download the data and join to another table.
Maura

--
Simon

Comment 1 Yaniv Lavi 2013-10-14 11:30:56 UTC
v(In reply to Simon Sekidde from comment #0)
> Description of problem:
> 
> Hi Yaniv, 
> 
> Adding the follow up questions in bugzilla from the inital email I sent
> dated below:
> 
> > From: "Simon Sekidde" <ssekidde@redhat.com>
> > To: "Yaniv Dary" <ydary@redhat.com>
> > Sent: Tuesday, September 17, 2013 10:28:30 PM
> > Subject: Questions regarding RHEVM reports on 3.2
> 
> >
> > 3. Add - hoc report prompted for user ID twice in DEV env
> > When a user creates an ad-hoc report in RHEV 3.2 or RHEV 3.1 and select one
> > of the download capabilities they get prompted for a user ID/PW twice. Is
> > this expected or should we just ignore these and run the report?
> 
> I don't understand the flow. Please explain.
> Screenshots? logs?
> 
> I logon to the reports Portal and run a report and it runs fine. I then
> select download to Excel, it starts running and then pops up with a logon
> the the Portal Again. I can click through that and then it pops up again and
> I click through it.   
> Maura

Screenshots? can you do a video recreation or a web session?


> 
> >
> > 5. Reports need to show user names not just IDs
> > We need a report that shows user names – not just IDs like "e12345678@domain"
> > is this in the works?
> 
> Where do you see user IDs?
> To my understanding "e12345678@domain" is [username]@[domain], is not what
> you are looking for?
> 
> To make the report valuable, we need the actual name of the user. If RH has
> this then that would be ideal.  Otherwise we have to download the data and
> join to another table.
> Maura

what report are you using?
What is the expected result?
Can we have a db dump?

> 
> --
> Simon

Comment 8 Simon Sekidde 2014-02-27 20:40:29 UTC
(In reply to Yaniv Dary from comment #7)

> So the rfe here is to add first and last name for users for use in users
> statistics? Please confirm.
> 
> 
> 
> Yaniv

Yes. That is correct.

Comment 12 Shirly Radco 2014-08-05 12:29:03 UTC
This feature had a bug 1124458. Delete date was not updated when user was removed. Please recheck.
Shirly

Comment 14 errata-xmlrpc 2015-02-11 18:14:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html