Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1010449

Summary: sometimes sat-sync does not import kickstart trees to the database
Product: Red Hat Satellite 5 Reporter: Stephen Herr <sherr>
Component: Satellite SynchronizationAssignee: Michael Mráka <mmraka>
Status: CLOSED NOTABUG QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 560CC: cperry, ghacker
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-09 20:23:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 924189    

Description Stephen Herr 2013-09-20 19:31:05 UTC
Description of problem:
Sometimes when you do a satellite-sync to pull in new base channels the kickstart trees are synced to disk but not imported to the database (or maybe the webui results are being cached). I don't know what causes the trees to import sometimes and what causes them to not. If you restart satellite they are visible.

Version-Release number of selected component (if applicable):
5.5

How reproducible:
sometimes

Steps to Reproduce:
1. satellite-sync a base channel
2. systems -> kickstarts -> profiles -> create new kickstart profile

Actual results:
no trees are listed as available in your base channel

Expected results:
trees are available

Additional info:
A very similar thing was reported before and fixed as bug 240137.

Comment 4 Stephen Herr 2013-10-09 20:23:02 UTC
After a bunch of code inspection and various attempts at reproducing, I have concluded that the problem must have been that Taskomatic was not running. The UI actually gets the list of available kickstart trees from cobbler, so if the cobbler-sync Taskomatic task has not run since your satellite-sync has finished you will not see the kickstart trees.

As such, I will close this as not a bug.